File Menu Options

In the File menu, you can open a variety of file formats, save your models into a variety of formats, and print.

  • The Part Viewer reads in HSF, HMF, STL, OBJ, and PLY files.
  • The Part Viewer can also read in the following image formats: JPEG, BMP, PNG, TIFF, and GIF.
  • If running a version of the Part Viewer with the appropriate RealDWG import libraries built in, you can open DWG and DXF files.

For your convenience, a set of demonstration HSFs is included on this distribution. They are separated into industry specific folders located in the datasets package, which is available for download from the Tech Soft 3D Developer Zone.

Saving Files

The Partviewer allows you to save models as

  • HSF: Saving Files as HOOPS Stream Files will create a compressed file of the graphical data within the scene. To ensure that Levels of Details (LODs) of objects in the scene are included in the HSF you must tell HOOPS to generate LODs for the scene. This is automatically done by turning on Levels of Detail when you set a constant framerate via the Frame Rate Options dialog in the view menu.
  • HMF: Saving Files as HOOPS Meta Files will create an uncompressed text file describing the graphical data within the scene.
  • HTML : This creates both a HTML page and a HSF which you can then post to your website as live 3D data. The HTML page has an embedded HOOPS 3D Control which will stream the HSF from either a local disk or a website. The embedded object will, behind the scenes, download and install the HOOPS 3D Control if it is not already installed on the machine reading the webpage. This means that developers simply need to put the HTML and HSF file on their Website and any user of MSIE can view the model over the web by simply pointing their browser to the page's URL.
  • EMF (Windows Encapsulated Metafiles): These files can be easily imported into any standard windows application. EMF output is used when you 'Copy to Clipboard'.
  • JPEG: These image files can be used to bring any of the data into any of the standard image editing software.
  • BMP: These image files can be used to bring any of the data into any of the standard image editing software.
  • GIF: These image files can be used to bring any of the data into any of the standard image editing software.
  • TIFF: These image files can be used to bring any of the data into any of the standard image editing software.
  • BHV: Saves the animation data of the scene in a a separate file as a collection of XML tags
  • PS: Outputs the scene as a Postscript file
  • HP: Outputs the scene as an HPGL/2 Plot file
  • CGM: Outputs the scene as a CGM Metafile
  • PDF (2D) : Outputs the scene as a 2D PDF file.
  • PDF (3D) : Outputs the scene as a 3D PDF file. Note: this will only work for a partviewer with U3D capabilities compiled into it.
  • U3D : Outputs the scene as a U3D file. Note: this will only work for a partviewer with U3D capabilities compiled into it.

Creating HTML Pages

HTML pages are created simply by saving the file as a HTML page. When you save a file as a HTML page two files will be created, a HTML file which references a newly created HSF file with the exact same filename. To publish your model to the web, simply copy both these files to your web site. The HTML page uses the HOOPS 3D ActiveX control which, if not already installed on your system, will be automatically downloaded and installed on your system when you view this HTML page. By default, the Part Viewer does not include Levels of Detail (LODs) in the HSF. Since LODs are ordered in the front of the file and are much smaller than the original objects they represent it is very beneficial to have LODs in the HSF. Through streaming the end-user can get a full, albeit coarse, representation of the scene even though only 5% of the total file may have been received. You can generate LODs for your scene by turning on Constant Frame Rates.

Printing/Print Preview/Print Setup/Print Options

The application supports standard Windows GDI Printing and Print Preview. It is also possible to set various options via the Print Options dialog; you can specify the resolution at which to print rastered images (up to the printer's maximum), you can force the image into grayscale, and you can break the image up into smaller installments so that the printer memory is not overloaded (this comes at the price of speed).

Although not currently implemented in this version of the application, developers could easily extend the output formats to include HPGL, Postscript, and CGM files.

top_level:4 api_ref/additional_resources:2 part_viewer/usage:0