View Menu Options

Changing the Viewing Projection

By default, the scene is rendered with a perspective viewing projection, you can change this to an orthographic viewing projection via the View menu.

Frame Rate Options

From the View menu, users may define the desired frame rate they wish the camera manipulators to maintain. When setting this option you can ask the application to generate different levels of detail. This causes HOOPS togenerate simplification levels for each body.

Detail Levels allows you to specify the number ofLevels of Details that should be generated for each shell, while the Falloff Value represents the percentage of vertices each succesive LOD should have. For example, a falloff value of 0.30 would mean that the Level 2 LOD would have 30% of the vertices of the Level 1 LOD. If desired, you can see the LOD levels directly via the LOD Level Menu Option from the View Menu.

If the system can't maintain the user specified frame rate, HOOPS will drop through the different simplification levels in order to keep up with the desired frame rate. Generating levels of detail has an associated one time pre-process cost which can be significant depending on the size of the model.

Turning on the Threshold LOD type will cause the application to utilise further HOOPS/3dGS logic to determine the LOD level on each body separately, depending on its triangle count per square window space unit. It is straightforward to implement these LODs using your custom code. See "level of detail options" under Set_Rendering_Options in the 3DGS reference manual.

Display Lists

From View menu, the "display list" driver option can be activated. This option only has an effect when using the OpenGL driver, and typically only causes a performance increase when the system has dedicated OpenGL hardware. Note that display lists do not support two-sided lighting. To compensate, we have provided two extra options in the View menu which allow the user to specify the handedness of the geometry in the scene.

Shadow Display

Display of Shadow for the objects in a scene can be toggled using the Shadow option from View menu. Shadow is displayed on the plane perpendicular to the current view-up vector.

top_level:4 api_ref/additional_resources:2 part_viewer/usage:0