Using the Partviewer

The Partviewer has been designed to work and act like any standard Windows application. It uses the MFC multi-document interface (MDI) supporting the standard MFC services (New, Open, Save As, Print, Print Preview, Copy to Clipboard). HOOPS Metafiles and Stream Filesmay be read, created, modified and viewed.

The Partviewer has the concept of an active render mode and an active model operator. The render modes can be toggled by using the "right click" menu while the model operators can be selected to invoke a camera manipulation, selection operator, geometry translate operator, or geometry creation/deletion operator. The operators can be made active by clicking on the appropriate icon or pull down menu.

Using The Toolbars
File Menu Options
Editing
Camera Manipulation
Creating And Selecting Geometry
Annotating The Scene
The Tools Menu
View Menu Options
Using The Context Menu
Direct Scene Manipulation
Modifying Application Settings
top_level:4 api_ref/additional_resources:2